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Abstract

1. Substrate complexity is an essential metric of reef health and a strong predictor of several ecological 

processes connected to the reef, including disturbance, resilience and associated community abundance and 

diversity.

2. Underwater SfM photogrammetry has been growing rapidly in use over the last five years due to 

advances in computing power, reduced costs of underwater digital cameras, and a push for reproducible 

data. This has led to the adaptation of an originally terrestrial survey technique into the marine realm, 

which can now be applied at the habitat scale.

3. This technique allows researchers to make detailed 3D reconstructions of reef surfaces for morphometric 

analysis of reef physical structural and large-scale image-mosaic mapping. SfM is useful for both reef-scale 

and colony-scale assessments, where visual or acoustic methods are impractical or not sufficiently detailed. 

4. Here we provide a protocol for the collection, analysis and display of 3D reef data, focussing on large-

scale habitat assessments of coral reefs using primarily open-source software. We further suggest 

applications for other underwater environments and scales of assessment, and hope this standardised 

protocol will help researchers apply this technology and inspire new avenues of ecological research. 

A
cc

ep
te

d 
A

rt
ic

le



This article is protected by copyright. All rights reserved

Introduction
The 3D structure of temperate and tropical reef ecosystems is a key predictor of benthic and demersal 

community structure, and of ecosystem disturbance and resilience (Graham & Nash, 2013; Ferrari, Bryson, et 

al., 2016; Zawada, Madin, Baird, Bridge, & Dornelas, 2019). Traditionally this element of the underwater 

environment has been recorded visually on a graded scale (Wilson, Graham, & Polunin, 2007), or using in-situ 

measures like the ‘tape-and-chain’ method (English, Baker, Wilkinson, & Wilkinson, 1997), or via a 

combination of visually and directly measured elements (Gratwicke & Speight, 2005). However, while these 

methods have proved useful for ecological studies, there is potential for observer bias, high variation according 

to placement, and non-repeatability (Bayley, Mogg, Koldewey, & Purvis, 2019).

The recent development of new technologies to record physical structures digitally, alongside rapid increases in 

computing power have allowed these traditional methods to be substantially improved upon. ‘Structure from 

Motion’ (SfM) photogrammetry (Westoby, Brasington, Glasser, Hambrey, & Reynolds, 2012) now allows us 

to create a detailed non-destructive 3D digital model of the physical environment from overlapping camera 

images. Models can be morphometrically analysed in a range of ways, and can be archived for future analysis 

and comparison by multiple observers (Anderson, Westoby, & James, 2019; Bayley & Mogg, 2019).

As this technology expands its use into underwater survey and research (from a largely terrestrial starting 

point), a range of methodologies are developing for creating and analysing 3D reef models, primarily over a 

small scale. However, there is still uncertainty for researchers new to this field over how to create their own 

models given the range of options available, and therefore a barrier to its standardised use in this setting from 

the initial training hurdles. 

We present an end-to-end protocol for how to create large-scale 3D models of reefs, common options for 

analysis of such models, and best-practice for storage and presentation of the outputs. We hope to aid 

researchers new to this approach by providing clear best-practice guidance to help fast-track and standardise 

the applications of photogrammetry within the community. We also hope it will inspire new avenues of 

ecological research, by summarising a range of approaches already in use.

 

Ecological applications 
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This paper specifically deals with the creation of models created from reef environments, however the SfM 

technique has been shown to be accurate and repeatable at a range of scales and across various habitat types 

above and below water (Ferrari, McKinnon, et al., 2016; Bryson et al., 2017; Raoult, Reid-Anderson, Ferri, & 

Williamson, 2017; Anderson et al., 2019; Bayley, Mogg, Koldewey, et al., 2019). 

Within the sphere of marine ecological research, this technology is being applied to analyse reef benthic 

community composition and habitat condition (Edwards et al., 2017; Bayley, Mogg, Purvis, & Koldewey, 

2019; Fukunaga, Burns, Craig, & Kosaki, 2019; Fukunaga, Burns, Pascoe, & Kosaki, 2020; Burns et al., 2020; 

Carlot et al., 2020), to inform associated community dynamics, and species behavioural interactions (González-

Rivero et al., 2017; Palma et al., 2019; Bayley & Rose, 2020; Tebbett, Streit, & Bellwood, 2020), and to assess 

changes in morphological complexity or growth through time (Lavy et al., 2015; Ferrari, Bryson, et al., 2016; 

Ferrari et al., 2017; Bayley, 2019; Magel, Burns, Gates, & Baum, 2019; Lange & Perry, 2020; Rossi, 

Castagnetti, Capra, Brooks, & Mancini, 2020). The technique is also being usefully applied to inform analysis 

of other marine and coastal systems, using drones and remotely operated vehicles (Casella et al., 2017; Teague 

& Scott, 2017; Palma et al., 2018; Castellanos-Galindo, Casella, Mejía-Rentería, & Rovere, 2019; Chirayath & 

Instrella, 2019; Price et al., 2019; Varela et al., 2019), making this a rapidly evolving and adaptable tool. The 

recent application of machine learning and convolutional neural networks to aid habitat / species classification 

of 3D mapped outputs will likely further widen the scope of this tool (Chirayath & Instrella, 2019; Hopkinson 

et al., 2020; Mohamed, Nadaoka, & Nakamura, 2020).

Limitations
Unlike laser or acoustic-based methods of structural assessment, SfM is primarily limited by lighting, visibility, 

and resolution as it is image-based. This can result in the loss of detail / accuracy in highly complex substrates 

due to objects creating areas of occlusion (i.e. obscured / shadowed areas where we cannot see, such as the 

centre of a densely branching coral stand). Adequate lighting, survey coverage, image overlap and camera 

equipment are therefore essential for creating accurate reef reconstructions (Aber, Marzoff, Ries, & Aber, 

2019). Official ISO data collection standards are however still being developed for this technique (Kresse, 

2010), therefore the level of consistency / comparability across outputs from varying cameras, operators and 

conditions is still to be fully explored. Finally, the size of current individual surveys is generally restricted to 

hundreds of square metres, primarily due to computer processing power limitations and time constraints 

(Bayley, Mogg, Koldewey, et al., 2019; D’Urban Jackson, Williams, Walker-Springett, & Davies, 2020).
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Pre-fieldwork preparation

Computer Storage / power

Photographic inputs for SfM can be relatively data-intensive (i.e. multiple gigabytes of data per survey), with 

reef-scale surveys averaging several thousand images and even small-scale reconstructions of complex objects 

requiring tens to hundreds of images. However, photographic detail is important, with higher resolution 

cameras enabling greater data capture and point-matching per image, as well as greater stand-off distances in 

clear waters. Adequate computing power is therefore essential as ~100 m2 of complex seabed may require 

~1000 images in order to produce a sufficiently detailed surface model. This data requires large amounts of 

RAM (≥32 GB), a powerful GPU (e.g. Nvidia GeForce range) and multi-core CPU (e.g. Quad-core Intel i7 or 

higher) to process in a sensible time period (i.e. hours versus days). Cluster processing the work over multiple 

nodes can considerably reduce processing time.

Image collection method for SfM

Survey area set-up (the ‘re-construction site’)

To mark out the site, we recommend initially tying off a Surface Marker Buoy (line taut to surface) with an 

attached waterproof GPS unit, to a non-living object (or to a fixed steel rebar stake / concrete block, if 

intending to re-survey over time). Note that while having multiple GPS-marked points is useful, in the field / at 

depth this can be impracticable and time consuming. Instead, one good GPS point, with recorded size and site 

orientation of the plot around this point, is preferable. Working from this initial point, lay a rough survey area 

using a reeled measuring-tape (Figure 1). This tape-laying element is optional but can help visualisation of the 

area during survey, particularly in low-visibility situations (i.e. visibility < site width). Next, distribute multiple 

objects / Ground Control Points (GCPs) of known dimensions (that are visible, non-mirrored, and weighted) 

across the survey area. Finally, set up a spirit-level (using a stable tripod), and take the depth and time at the 

top of the level. Inclusion of a spirit-level with compass allows accurate assessment of site slope 3-dimensional 

(XYZ) orientation and cardinal direction. Where using an ROV / drone, paired lasers can be used for size 

calibration. 
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Figure 1. The typical conceptual layout of equipment over the substrate in preparation for photogrammetric survey. 1) a 

permanent visible marker (taped steel rebar) standing ~1 m proud of the reef; 2) small corner-marker tags to aid re-

location of the survey area; 3) in-situ markers / Ground Control Points (GCPs) of known XYZ (3D) dimensions; 4) 

measuring tape detailing the survey extent; and 5) in-situ spirit-level and compass for calibration and additional scaling 

to XYZ planes. Right panels show the direction of movement (black line) by the surveyor for a reef or colony scale 

assessment. Reef-scale patterns are depicted as from above.

Image collection / Swim pattern

Swim over the area, pointing the camera down towards the substrate at a roughly perpendicular / oblique angle, 

1-2 metres above the substrate for habitat-scale assessments. Photograph the area of interest, spirit-level, and A
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markers / GCPs, with the sequential images overlapping by 50 – 75%. The initial image should capture a slate, 

detailing survey site, replicate, date, time and depth.

The survey pattern used to collect underwater imagery will vary according to the scale of survey (colony vs. 

reef), the reef complexity, and the angle of slope. Common approaches apply a ‘lawn-mower’ pattern zig-

zagging over the substrate (Burns, Delparte, Gates, & Takabayashi, 2015), or an expanding spiral pattern 

(Pizarro, Friedman, Bryson, Williams, & Madin, 2017), which can be beneficial in lower visibility 

environments (Figure 1). The exact angle of shots will vary according to the substrate, with the techniques all 

aiming to attain good coverage while minimising occlusion and blue-water image space. 

Scale – habitat vs colony

Survey area coverage will vary according to the aims of the study (Lechene, Haberstroh, Byrne, Figueira, & 

Ferrari, 2019), ranging from a few cm2 (assessing individual colonies or polyps) to many hundred m2 

(assessing habitat-scale / multi-colony changes). Within a 1 hour dive in clear still conditions, a buddy team 

can expect to be able to survey at least 400 m2 planar area of contiguous moderately complex substrate. Site-

specific hydrology, lighting, structure, depth and slope conditions will all affect the total amount of time 

needed and therefore the feasible survey coverage. Scale of assessment and associated detail will also affect the 

outputs, with the number of photos needed per m2 increasing as scale decreases (i.e. as the need for fine-scale 

detail increases).

Camera settings for image capture

SfM photogrammetry can be conducted using a single camera, however an array of linked (e.g. remote release 

connected DSLRs) or time-lapsing cameras of the same model and settings can also be used in order to 

increase area coverage within the survey time (Figure 2). Metashape will automatically calibrate (and group) 

cameras during optimization providing EXIF data is present. If not, parameters must be added using the 

Camera Calibration tool. 

Multiple camera types are now available for underwater photography (Neyer, Nocerino, & Gruen, 2019; 

Nocerino et al., 2019). While GoPros are ideal for rapid and affordable assessment in optimal conditions, for 

the best quality outputs in terms of resolution, alignment and adaptability, we broadly recommend a DSLR A
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with a large, high MegaPixel image sensor (ideally full frame / ≥ 1” with global shutter), and a flat, fixed focal 

length ‘prime’ wide-angle lens (i.e. ~20 mm) with auto-focussing. This allows adaptability to varying 

underwater environments and wide field of view. Ensure the same camera model and lens focal length is used 

for any one survey, as variations will cause processing issues (Lavy et al., 2015).

Take care with image exposure and re-assess frequently. A good aperture for images is ~ 5.6, with a fast shutter 

speed to limit low-light image blur (i.e. 1/125 or faster, altered frequently as ambient light changes), and 

moderate ISO (i.e. 200-400) to compensate without adding grain. White-balance needs to be set at the start of 

each survey to an in-situ colour reference. Adequate strobe lighting becomes essential at increased depth or 

within more turbid waters. Ensure the angle of the lighting is oblique rather than directly on to the subject, and 

use a diffuser to minimise backscatter and give even illumination.

A
cc

ep
te

d 
A

rt
ic

le



This article is protected by copyright. All rights reserved

Figure 2. A) A diver using a hand-held DSLR camera to survey a coral reef using the SfM technique; B) Example camera 

configurations for short-range photogrammetry underwater (wide-angle DSLR / compact / paired action-cameras, with 

video lights / strobes); C) resulting dense pointcloud layer of a 100 m2 reef section, with individual photo locations shown 

in blue.

In clear water conditions with adequate ambient or video-lighting, quality wide-angle action cameras such as 

GoPro (with large image sensors) can be used, typically applying the time-lapse function (~1 frame/second). 

Video footage can also be used, however this involves an additional step of ‘frame-grabbing’, which can take 

time and reduce image quality. With older video cameras it is advisable to use a non-interlacing video format 

to retain high quality outputs. A
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Ensure any underwater equipment is washed daily and is periodically inspected to ensure continued use 

throughout a survey campaign, with no loss of data, quality, or time.

Photogrammetric processing

Processing of images

A range of commercial and open-source software is now available for creating topographic 3D models through 

SfM (Anderson et al., 2019). Popular commercial tools currently include Agisoft Metashape (previously 

‘Photoscan’), Pix4D, Autodesk, and Photomodeler. Open-source tools include VisualSFM, COLMAP, 

Regard3D, OpenDroneMap, and Bundler, which each vary in the degree of user control, outputs available, 

photo number-limit, and processing time. We recommend the use of Agisoft Metashape for SfM processing of 

reef imagery, due to its affordable price, wide use, good technical support, and easy control over processing 

and outputs. Table 1 details our recommended process for SfM-derived reef model creation. For in-depth 

discussion on camera trade-offs, optimal calibration, processing / alignment error mitigation, and post-process 

error reduction whilst using underwater SfM techniques, see (James & Robson, 2014; Lavy et al., 2015; Bryson 

et al., 2017; Marre, Holon, Luque, Boissery, & Deter, 2019; Neyer et al., 2019; Nocerino et al., 2019; Shortis, 

2019; Suka et al., 2019; Agisoft LLC, 2020; Lange & Perry, 2020).
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Table 1. A workflow detailing the steps recommended to create a 3D reef pointcloud using SfM, following initial image collection.

Model Creation Workflow

Project creation and image alignment

Step Action

1 Collect field imagery (label images sequentially as captured) and back-up the data

2 Import imagery to an Agisoft Metashape project (1 reef or colony per chunk). Camera and lens type 

is detected automatically from image metadata, but can be specified further to increase accuracy 

(Tools > Camera calibration).

3 Save the project with a sensible and informative naming convention i.e. 

'SiteName_Block#_Depth#_Replicate#.psx'

4 Align imagery to create a sparse pointcloud (Workflow > Batch process > Add > Job type = Align 

Photos > Apply to = All / unprocessed / selected chunks, Save project after each step = True).

- Default settings (Accuracy = High, Generic preselection = Yes, Key point limit = 40,000, Tie point limit 

= 4,000). All batch job settings can be saved as an .xml file.

- For difficult to align models deselect 'generic preselection', change key and tie points to = 0 (infinite). 

Note processing time will significantly increase.

Error reduction & scaling

Step Action

5 Optimize camera alignment (Workflow > Batch process > Add > Job type = Optimize alignment > 

Apply to = All / unprocessed / selected chunks. Save project after each step = True, Settings = 

Default).

6 Reduce model errors and increase accuracy using (Model > Gradual Selection). Reconstruction 

Uncertainty (Level aim = ~10, max 50); Projection Accuracy (Level aim = ~3). 

- For both error reduction stages in Step 6, if more than 50% of points are selected, increase the level 

to a higher value and then repeat iteratively. Repeat Step 5 after each error reduction.

7 Add reference markers to in-situ ' Ground Control Points' within the photo view (right click > Add 

marker). Ensure correct placement of markers on visible ‘GCPs’ in all overlapping photos.

- Note, reference markers can also be added to in-situ 'Ground Control Points' within the model view A
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following dense cloud creation, which is faster but can lead to increased calibration error.

8 Scale model using at least three marker pairs (select two marker points > right click > Create scale bar 

> add distance in metres > update model). Scale Bars Error should be ≤ 0.005 m, aiming for ~ 0.002 m 

over a >10 m site. Include known Z value (depth) if available.

- Note that stationary in-situ Agisoft-generated ‘coded targets’ can also be used to automate this 

scaling process and aid alignment (Tools > Markers > Detect Markers).

9 Reduce RMS reprojection error. (Model > Gradual Selection > Reprojection Error, Level aim = ~0.3). If 

more than 10% selected, increase level. Repeat iteratively until level reached.

- We recommend completing stage 5 - 9 manually. For a fuller description of this process see: 

https://uas.usgs.gov/nupo/pdf/USGSAgisoftPhotoScanWorkflow.pdf

10 Complete processing steps 4 - 9 first and check results before moving on to next steps if using the 

batched workflow. Steps 5 – 6 are non-essential but will reduce systematic errors and are therefore 

recommended.

Dense cloud creation, cleaning and orientation

Step Action

11 Build dense cloud (Batch process > Add > Job type = Build dense cloud > Apply to = All / unprocessed / 

selected chunk).

- Default settings (Quality = High*, Depth filtering = Aggressive, Calculate point colours = Yes, Calculate 

point confidence = Yes) * changeable depending on required level of detail.

- For highly complex surfaces 'Moderate' depth filtering may be more appropriate.

- This step (and steps 16-18) can be run as a single batch file for multiple 'chunks' (i.e. multiple reef 

surveys) in a single project, and run overnight.

12 Select & crop the Dense Cloud to the area of interest (reducing file size / process time) e.g. (Model > 

Rectangle Selection; Edit > Crop Selection).

13 Clean surface layer by selecting and deleting anomalous point scatter (rotate object with mouse > 

Free-form selection tool > select anomalies > Delete selection). To automate filtering out low 

confidence points / noise (Tools > Dense cloud > Filter by confidence, adjust tolerance as required. 

Low confidence = approximately ≤ 2).

14 Reset View. Resize region to encompass full model, if required (Model > Transform Region). Rotate A
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Object for a bird's eye view of the surface (Model > Transform Object > Rotate Object); Y = up 

(North), X = right (East), Z = vertical. If using a spirit-level, place markers (in model view) on top of the 

level and input relative X,Y, and Z values in Reference pane (Z values should all be equal, and relate 

to depth in metres).

15 Export surface layer (File > Export points > Save Type = XYZ point cloud (*.txt) > Source data = Dense 

cloud > point colours & normals = selected).

 Additional model outputs (DEM / orthophoto / textured mesh / shapes)

Step Action

16 Create DEM (Batch process > Add > Job type = Build DEM > Source data = Dense cloud > Apply to = All 

/ unprocessed / selected chunk).

17 Create Ortho-mosaic (Batch process > Add > Job type = Build Orthomosaic > Surface = DEM or Mesh 

> Blending mode = Mosaic > Apply to = All / unprocessed / selected chunk).

18 Create a Triangulate Irregular Network (TIN) mesh and textured surface for visualisation and display 

(Batch process > Add > Job type = Build Mesh (Default settings, source data = dense cloud, quality = 

High) > Apply to = All / unprocessed / selected chunk); Add > Job type = Build Texture (Default 

settings, blending mode = Mosaic, Texture size/count = 16384) > Apply to = All. 

19 Shapes delineating areas / features of interest in the model can be created and exported as .SHP files 

(i.e. Model > Draw polyline/Polygon/Point; File > Export > Export Shapes).

20 All above elements can be integrated within a Python workflow.

Morphometric analysis of reefs

Surface / community analysis

There are a diverse array of outputs and approaches possible for reef ecology using SfM, summarised in Figure 

3. A number of methods are now available to analyse the resulting SfM-derived 3D surface morphometrics, 

which range in complexity, software cost, and user-training: ArcGIS (Burns et al., 2015; Fukunaga et al., A
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2019); SLAM / Python-based (Friedman, Pizarro, Williams, & Johnson-Roberson, 2012; Ferrari, McKinnon, et 

al., 2016; González-Rivero et al., 2017); Fledermaus (Storlazzi, Dartnell, Hatcher, & Gibbs, 2016); Rhino 

(Young, Dey, Rogers, & Exton, 2017); GeoMagic (Ferrari et al., 2017); Meshlab/Blender (House et al., 2018); 

R (Schlager, 2019); or machine learning / neural network classification (Chirayath & Instrella, 2019; 

Hopkinson et al., 2020; Mohamed et al., 2020).

Figure 3. A non-exhaustive summary of applications and outputs available from the use of Structure from Motion photogrammetry for 

coastal and marine science.

We recommend using the open-source software ‘Gwyddion’ (Nečas & Klapetek, 2012) for 3D surface analysis, 

which produces a wide diversity of topographic outputs. The software has extensive online documentation, and 

can be integrated to open-source workflow pipelines such as Python/R. It is important to note however that this 

method creates an interpolated/rasterised layer based on point height, and will therefore not fully account for 

overhanging objects (similarly to topobathic Lidar / Sonar techniques). We recommend a protocol for reef 

surface analysis in Table 2 using Gwyddion. This method assesses reef surfaces using both a virtual transect 

and virtual quadrat, resulting in a wide range of possible output metrics.A
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For analysis of substrate community composition / distribution / cover etc., HD ortho-rectified image-mosaics 

and Digital Elevation Models (DEMs) can also be exported from Agisoft Metashape (Table 1) and integrated 

into commonly used workflows, such as ‘Coral Point Count (CPCe)’ software in JPG format, or within ArcGIS 

in ASCII/GeoTIFF format respectively. 

Table 2. A workflow detailing the steps recommended to analyse a 3D reef surface model, using a virtual transect or 

virtual quadrat method. 

3D Surface Analysis Workflow

Data import and conversion

Step Action

1 Import the exported XYZ layer (.txt) file to Gwyddion - 64 bit (File > Open> [Browse / select file] > 

Lateral units = m, value units = m). Note down X,Y and Z distance ranges.

- Ensure ‘XYZ file type’ is selected rather than auto-detect option.

- Note that the 64-bit version is more stable for larger files sizes (i.e. 500 MB+), but the 32-bit version 

allows Python integration.

2 Convert XYZ data to interpolated layer (XYZ data > Rasterise > Horizontal size = (link length required 

in px / m) > Make pixels square > Interpolation type = Average > Exterior type = Mirror).

3 Level dataset’s relative height so that the lowest point = 0 (Data process > Shift minimum data value 

to zero).

4 If required, flip the layer to match original orientation (Data process > Basic Operations > Flip 

vertically / horizontally / both)

Virtual transect (2D) method

Step Action

 Virtual transect (2D) method:

5 Extract linear surface data (Tools > Calculate roughness parameters > Cut-off = 0 (typically), Thickness 

= 10 px (points averaged), Interpolation type = Linear > Result formatting = CSV). 

6 [Click / select a profile line on the separate rasterised topography window from step 2] > Save results 
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to file [naming = '####.csv']> Repeat profile lines as required.

7 Use R script (supplementary data) to amalgamate multiple individual CSV files to one spreadsheet - 

or do so manually.

Virtual quadrat (3D) method

Step Action

8 Extract 3D surface data (Tools > Statistical Quantities [specify location (X/Y) and size (width/height) of 

area over rasterised topography window] > Resulting format = CSV > Save results to file [naming = 

'####.csv'] as above > repeat as required).

9 Extract Fractal dimension of whole surface (Data Process > Statistics > Fractal Dimension > Method = 

Power spectrum / Triangulation / Cube counting / Partitioning > Result formatting = CSV > Save 

results to file [naming = '####.csv']).

- If sub-sampling the rasterised surface layer (Tools > Crop > [Select area of interest] > Create a new 

image = Selected > OK).

10 Use R script (Supplementary data) to amalgamate multiple individual CSV files to one spreadsheet - 

or do so manually.

Volumetric analysis 

We recommend using the open-source software ‘Cloudcompare’ to simply align multiple reef surface models 

and to calculate the 2.5D volume change between pointcloud layers (Table 3).
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Table 3. A workflow detailing the steps recommended to analyse volumetric change between two reef models over time.

Volume Change Analysis Workflow

Data import, alignment, and calculation

Step Action

1 Import two XYZ surface layers (.txt files) of interest into Cloudcompare 

2 Roughly align the two layers using the ‘Equivalent point pairing’ tool ([select both clouds of interest] > 

Tools > Registration > align (point pairs picking) > Choose 'reference' and 'aligned' roles for layers 

(oldest / before layer typically the reference) > [Select at least 4 matching point pairs based on fixed 

in-situ markers or objects]).

 - Note that the alignment points / markers need to be arranged in a non-linear pattern, dispersed 

around the area of interest (i.e. four rebar markers placed at each corner of the quadrat).

 Note, layers should ideally be the same size. If one layer is larger than the other this should 

preferably be the bottom layer, therefore additional cropping may be needed.

 - Note, If you need to reduce the layer file size, select 'subsample a point cloud' and choose the 

minimum resolution needed.

3 Finely align the two pointcloud layers using the ‘Iterative Closest Point’ tool (Tools > Registration > 

Fine registration (ICP) > [select reference / aligned layers] > [select RMS difference] typically = 1.0e-

5).

4 Crop to the area of interest, including only the regions with a top and bottom pointcloud area (Edit > 

Segment).

5 Compute 2.5D volume difference between layers with the reference layer typically the earliest of the 

two surveys or the 'before' layer (Tools > Volume > Compute 2.5D volume > [Select floor and ceiling 

layer] > Empty cells = interpolate > Grid step = [resolution of layers in metres, i.e. 0.005) > Projection 

direction = Z > cell height = average > Update).

 - To visualise results: select ‘Export grid as cloud’ and use the properties for the new height difference 

raster to adapt the colour and parameters.

 - Graph the height differences using (show histogram).

 - Save / export results and outputs by selecting your layers of interest.
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Data storage / accessibility

Structure & metadata

For efficient storage of raw and processed data we recommend following established ISO compliant folder 

structure systems, such as the British Geological Society (BGS) marine survey system (https://www.bgs.ac.uk), 

and following MEDIN (or similar) metadata standards (https://www.medin.org.uk/data-standards). We 

recommend the daily download of all captured data in the field, followed by the creation of back-up copies. 

Labelling and filing of imagery should be completed on the day of collection to avoid confusion, along with 

formatting of camera memory cards before each re-use.

Data sharing / storage platforms

For increased accessibility and data-sharing of 3D layers, alongside traditional storage solutions there are a 

number of online platforms designed to accommodate this specific data type, such as Morposource 

(morphosource.org), 3Dmapping (3dmapping.cloud), Pointbox (pointbox.xyz), and Dronelab (dronelab.io), 

which allow users to store and view meshes, pointclouds, and orthomosaics online for low to no cost. 

Visualisation

A number of online platforms now exist for sharing interactive 3D models (e.g. Sketchfab, Sketchup, ArcGIS 

online, and Oculus Unity), though models must typically be decimated in order to be uploaded, losing detail. 

Models must be further decimated in order to create Virtual Reality (VR) compatible outputs, so maintaining 

high mesh texture sizes is essential.

For science communication, Metashape’s animation pane allows users to create either a basic rotational 

animation, or a more complex flightpath. Animated fly-throughs can alternatively be created using previously 

mentioned software options, such as CloudCompare, Blender, and Fledermaus. We recommend exporting the 

resulting capture at 3840x2160 (16:9) resolution to produce high quality animations. 
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Conclusions
The 3D analysis and mapping of reefs using SfM modelling is likely to revolutionise marine monitoring and 

rapidly become standard practice, allowing a suite of new questions to be quantitatively assessed (Obura et al., 

2019). Detailed substrate data can be captured and stored indefinitely allowing interrogation with constantly 

evolving analytical tools, and integration within large-scale assessments (Madin, Darling, & Hardt, 2019). The 

initial capture methods must therefore be rigorous and methodological, and care must be taken whilst planning 

long-term surveys in order to ensure direct comparisons can be made over time. The protocol described here 

has been developed over several years and is focused on providing a low-cost and efficient workflow for the 

production of structural data to a high quality. However, this technology and the range of applications to which 

it can be applied are of course still relatively young and so are rapidly evolving. Protocols such as ours will 

consequently continue to develop and change at pace as more of the marine community uses the technology. 

As camera equipment improves and both the costs and time of processing decrease, we hope to see this 

technology become even more widespread and a standard tool within ecological survey.   
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